Recent Maven Wrapper Updates

Within the last while I have ended up doing a whole bunch of merges on the maven-wrapper and the related takari-maven-plugin. In the end (fingers crossed) we are now at maven-wrapper: 0.5.4 and takari-maven-plugin:0.7.5. That includes a whole bunch of great changes …

So let’s see – we got some really good features added and as usual more details can be found in the documentation for the wrapper and the plugin:

  • update to default to Apache Maven 3.6.0 (latest release)
  • consistent support for MVNW_VERBOSE flag
  • support for proxy servers including authentication
  • support for MVNW_REPOURL for usage with internal repository managers overriding content of maven-wrapper.properties URL values
  • improved Windows support including cygwin usage and changes for TLS1.2
  • cleaned up file permissions

These changes really take the wrapper usage to the next level, so go and try it out!. And if you really find another issue, we are still happy to hear from you and get a PR with fixes 😉

Manfred

Update 2019-04-16: cut another release that changes the default to the new Maven 3.6.1

Leave a Reply

Required fields are marked *.